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Tóm tắt: Trắc nghiệm khách quan trong kiểm tra đánh giá đã và đang được 

sử dụng trong hầu hết các môn học ở Đại học. Nhiều vấn đề đặt ra trong việc 

xây dựng các bộ đề trắc nghiệm như độ khó, dạng trắc nghiệm và hình thức 

trắc nghiệm. Trắc nghiệm dạng đồ họa đang là một vấn đề được quan tâm 

nhằm nâng cao khả năng tương tác ảo và nâng cao chất lượng dạy học. Bài 

báo này giới thiệu cách thức sử dụng phần mềm Macromedia Flash trong 

việc tạo các câu hỏi trắc nghiệm đồ họa với một số hình thức khác nhau. 

Trên cơ sở đó, chúng tôi đã vận dụng để xây dựng bộ đề trắc nghiệm đồ họa 

cho học phần Kiến trúc máy tính. 

Từ khóa: Trắc nghiệm đồ họa, Trắc nghiệm kiến trúc máy tính, Trắc 

nghiệm online 

 

1. ĐẶT VẤN ĐỀ 

Kiến trúc máy tính là môn học quan trọng trong đào tạo chuyên ngành Công nghệ thông tin, 

đối tượng nghiên cứu chính của nó là máy tính và các chức năng của máy tính. Môn học 

này vừa có tính cụ thể vừa có tính trừu tượng, vừa có tính lý luận vừa có tính thực tiễn, và là 

môn học được đánh giá cao ở năng lực vận dụng vào thực tiễn. 

Tính cụ thể và tính trừu tượng 

* Tính cụ thể: Nội dung môn học bao gồm các kiến thức về máy tính, các linh kiện máy 

tính. Cụ thể đó là các cấu trúc của các thiết bị, các quy trình hoạt động, các kỹ năng, kỹ xảo 

trong lắp ráp và vận hành.  

* Tính trừu tượng: nội dung học còn có các kiến thức về giải thuật, thuật toán bên trong 

máy tính. Đây là những kiến thức mang tính trừu tượng cao. Để lĩnh hội được những kiến 

thức này không những đòi hỏi sự tương tác trực tiếp với máy tính mà còn yêu cầu đối với 

giáo viên cần phải có mô phỏng, mô hình trực quan có tính tương tác cao đối với học viên, 

sử dụng ngay trên máy tính để mô tả cái giải thuật diễn ra bên trong nó. 

Tính lý luận và tính thực tiễn 

* Tính lý luận: Các cấu trúc, các thuật toán trong lập trình của tin học đòi hỏi phải có tính 

logic và tính tối ưu hoá. 

* Tính thực tiễn: Các kiến thức về môn học được áp dụng nhiều vào đời sống thực tiễn như: 

thiết kế, sản xuất, lắp ráp và sử dụng máy vi tính. 
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Với những đặc điểm trên yêu cầu đặt ra để kiểm tra đánh giá trắc nghiệm môn học này 

trong đào tạo trực tuyến là: 

Một là: Kiểm tra các kiến thức về các thành phần, thông số kỹ thuật cơ bản của 

linh kiện, quy trình, nguyên lý hoạt động:  

Phần này có thể sư dụng các câu hỏi đánh giá trắc nghiệm dạng text. Chúng tôi đã xây 

dựng ngân hàng 400 câu hỏi để kiểm tra đánh giá trực tuyến [5]. 

Hai là: Kiểm tra các kiến thức như: nhận dạng thiết bị, lắp ráp thiết bị, phân biệt 

các thành phần trên một hệ thống:  

Để kiểm tra đánh giá phần này có hiệu quả cách tốt nhất là thực hiện trên thiết bị thực ở 

phòng thực hành, tuy nhiên điều này là khó khăn vì đây là môi trường đào tạo trực 

tuyến (môi trường học tập ảo). Ở đó không thể có phòng thực hành với các thiết bị trực 

quan như trong đào tạo truyền thống. Và phần này không thể sử dụng câu hỏi trắc 

nghiệm dạng Text để kiểm tra đánh giá có hiệu quả được vì đây là phần kiểm tra đánh 

giá trực quan. 

Để có thể thực hiện kiểm tra đánh giá được nội dung này có hiệu quả, chúng tôi đưa ra 

một giải pháp đó là sử dụng bộ đề trắc nghiệm đồ họa trong đánh giá trực tuyến học 

phần Kiến trúc máy tính. 

3. TRẮC NGHIỆM KHÁCH QUAN  

Theo [1], [2], [3], [4], trắc nghiệm là một hoạt động để đo lường năng lực đối tượng nào 

đó nhằm những mục đích xác định. Thi trắc nghiệm là hình thức mà một đề thi gồm rất 

nhiều câu hỏi, mỗi câu hỏi nêu ra một vấn đề cùng với những thông tin cần thiết sao cho 

học viên chỉ trả lời vắn tắt cho từng câu hỏi.  

Trắc nghiệm là một phương pháp đánh giá kết quả học tập của sinh viên trong đó ảnh 

hưởng của các yếu tố chủ quan đã được giảm thiểu đến mức tối ưu. Điểm nổi bật của 

phương pháp này là số lượng câu hỏi trong mỗi đề thi lớn, số câu hỏi càng lớn, độ chính 

xác của việc đánh giá càng cao. Câu hỏi trắc nghiệm sẽ gồm một khái niệm, nội dung dã 

có trong chương trình, kèm theo gợi ý để học viên trả lời. Từ cách gợi ý trả lời ta sẽ có 

nhiều câu hỏi trắc nghiệm khác nhau. 

3. TRẮC NGHIỆM ĐỒ HỌA HỌC PHẦN KIẾN TRÚC MÁY TÍNH 

Theo [1] trắc nghiệm được chia thành 5 dạng câu hỏi chính sau: Trắc nghiệm có nhiều 

lựa chọn, trắc nghiệm "đúng- sai", trắc nghiệm ghép đôi, trắc nghiệm điền khuyết, trắc 

nghiệm bằng hình vẽ (kênh hình). Để xây dựng được một bộ đề thi trắc nghiệm đồ họa 

(sử dụng hình ảnh để kiểm tra đánh giá) phù hợp cho học phần kiến trúc máy tính, 

chúng tôi xin được để xuất sử dụng 3 dạng câu hỏi trắc nghiệm sau: 

Dạng thứ nhất: Trắc nghiệm dạng ghép đôi 

- Các câu hỏi được tổ chức dưới dạng 2 nhóm đối tượng (hình ảnh), học viên cần kéo và 

thả các đối tượng thuộc nhóm thứ nhất vào một đối tượng thuộc nhóm thứ 2 để ghép. 
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- Dạng bài tập này được áp dụng để kiểm tra đánh giá khả năng lắp ráp các linh kiện 

máy tính của học viên. Để làm được bài tập này đòi hỏi học viên phải có kiến thức tổng 

hợp về các linh kiện máy tính như: Các thông số kỹ thuật cơ bản, đặc điểm cấu tạo, 

nhận dạng thiết bị, vị trí lắp đặt đồng thời phải biết phân tích để lựa chọn thiết bị. 

Dạng thứ hai: Trắc nghiệm dạng lựa chọn đối tượng. 

- Câu hỏi được tổ chức dưới dạng một nhóm (4 đối tượng trở lên), học viên sẽ chọn một 

hoặc nhiều đối tượng theo yêu cầu của câu hỏi. 

- Dạng bài tập này dùng để kiểm tra việc vận dụng kiến thức của học viên vào thực tiễn 

vì để làm bài tập này học viên cần hiểu biết về các thông số cơ bản của linh kiện, nhận 

dạng thiết bị và cách thức sử dụng các thiết bị đó trong thực tế. 

Dạng thứ ba: Trắc nghiệm lựa chọn vị trí trên một đối tượng: 

- Câu hỏi được tổ chức dưới dạng một bức ảnh nào đó và người làm bài cần chọn một vị 

trí trên bức ảnh là đáp án đúng. 

- Dạng bài tập này dùng để kiểm tra khả năng nhận biết, phân biệt các chi tiết trong một 

khối tổng thể (Ví dụ: Nhận biết đâu là socket trên mainboard, đâu là thông số thể hiện 

bộ nhớ Cache của CPU,…) của học viên trong thực tiễn. Để làm bài tập này đòi hỏi học 

viên phải nắm chắc về cấu tạo của các linh kiện máy tính, cách đọc các thông số kỹ 

thuật trên thiết bị thực. 

4. XÂY DỰNG BÀI KIỂM TRA TRẮC NGHIỆM ĐỒ HỌA 

4.1. Công cụ xây dựng trắc nghiệm Macromedia Flash 

Hiện nay đã có nhiều công cụ được sử dụng để tạo bộ đề trắc nghiệm trong E-learning 

như: Hot Potatoes, Lacture Maker, Adobe Presenter, Moodle,… Điểm yếu của những 

phần mềm này là khả năng tạo các câu hỏi trắc nghiệm dạng đồ họa. Để đáp ứng được 

yêu cầu đặt ra trong xây dựng bộ đề trắc nghiệm kiến trúc máy tính chúng tôi lựa chọn 

công cụ Macromedia Flash. Đây là một công cụ đồ họa thiết kế hoạt hình 2D, với khả 

năng đồ họa 2D mạnh của mình nó còn được ứng dụng trong E-learning để xây dựng 

bài giảng điện tử, mô phỏng, tạo bộ đề trắc nghiệm. Một ứng dụng chúng tôi đề cập 

trong bài báo này đó là sử dụng Macromedia Flash để tạo bộ đề trắc nghiệm đồ họa. 

Macromedia Flash hỗ trợ 6 dạng câu hỏi trắc nghiệm: 

- Dạng1: True – False: Mỗi câu hỏi thường có hai lựa chọn và trong đó một lựa chọn 

được xác định là ĐÚNG, một lựa chọn được xác định là SAI. 

- Dạng 2: Multiple Choice: Mỗi câu hỏi thường có nhiều lựa chọn và một số trong đó 

được xác định là đáp án đúng. 

- Dạng 3: Fill in the Blank: Mỗi câu hỏi có một ô để người làm bài nhập giá trị của đáp án.  

- Dạng 4: Drag and Drop: Mỗi câu hỏi thường được chia làm hai phần. Người làm bài 

cần kéovà thả các đối tượng vào những vị trí tương ứng thích hợp. 
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- Dạng 5: Hot Spot: Mỗi câu hỏi thường được thể hiện bằng một bức ảnh nào đó và 

người làm bài cần chọn một vị trí thích hợp trên bức ảnh đó. 

- Dạng 6: Hot Object: Mỗi câu hỏi thường có nhiều đối tượng và người làm bài cần 

chọn bằng cách nhấn chuột lên một trong các đối tượng đó. 

Dạng 1, dạng 2, dạng 3 đã được nhiều tác giả nghiên cứu, vận dụng để xây dựng bộ đề 

trắc nghiệm dạng text. Trong bài báo này chúng tôi nghiên cứu và vận dụng: dạng 4, 

dạng 5, dạng 6 để xây dựng bộ đề trắc nghiệm hình ảnh cụ thể như sau: 

- Dạng 4 sử dụng để xây dựng câu hỏi trắc nghiệm hình ảnh dạng ghép đôi.  

- Dạng 5 sử dụng để xây dựng câu hỏi trắc nghiệm hình ảnh dạng lựa chọn đối tượng. 

- Dạng 6 sử dụng để xây dựng câu hỏi trắc nghiệm hình ảnh dạng lựa chọn vị trí trên 

một đối tượng. 

4.2. Xây dựng bộ đề trắc nghiệm đồ họa với Macromedia Flash 

a. Cấu trúc một bộ đề trắc nghiệm 

Một bộ đề dựa trên mẫu trắc nghiệm có sẵn mà phần mềm hỗ trợ bao gồm các thành 

phần sau: 

- Trang giới thiệu (Welcome page) 

- Trang các câu hỏi (Question page) 

- Trang kết quả (Result page) 

- Các nút bấm để di chuyển giữa các câu hỏi 

- Mã chương trình 

b. Tạo bộ đề trắc nghiệm 

Bước 1. Khởi tạo đề từ mẫu 

- Thực hiện lệnh File -> New -> Template 

- Trong cột Category chọn Quiz.Trong cột Template chọn một trong số 3 mẫu được 

cung cấp. 

Bước 2. Thiết lập các thông số cơ bản 

- Bấm chọn Quiz Options (bên trái cửa sổ trình bày - Stage) 

- ChọnWindow -> Development Panels -> Component Inspector 

Các tham số bao gồm: 

+ Randomize: Nếu được chọn, các câu hỏi sẽ hiển thị theo thứ tự ngẫu nhiên. Như vậy, 

giữa các lần chạy khác nhau, gần như có các đề kiểm tra khác nhau. 

+ Question to Ask: Nhập số câu hỏi sử dụng cho mỗi lần kiểm tra. Nếu giá trị là 0, mọi 

câu hỏi trong bộ đề sẽ được sử dụng. Thông thường, giá trị này nhỏ hơn số câu hỏi 
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+ Show Result Page: Nếu được chọn, trang kết quả sẽ xuất hiện sau khi kiểm tra xong, 

thông báo cho biết đã làm đúng bao nhiêu câu trên tổng số bao nhiêu câu. 

+ Các lựa chọn khác dùng để thiết lập khi có hệ thống kiểm tra trắc nghiệm trực tuyến 

với Server đầy đủ. 

Mỗi câu hỏi trong bộ đề được gọi là một Interaction. Khi sử dụng Quiz Template, các 

câu hỏi được đặt liên tiếp nhau thành các keyframe(khung hình chính) nằm giữa 

keyframe thứ nhất và keyframe cuối cùng. Keyframe thứ nhất chính là Welcome page, 

có thể thay đổi giao diện tùy thích. Keyframe cuối cùng chính là trang hiển thị kết quả. 

Các Keyframe hiển thị trên Interactions Layer. Để thay đổi câu hỏi hay soạn thảo câu 

hỏi, chuyển đến các Keyframe nằm giữa Keyframe thứ nhất và Keyframe cuối cùng. 

Đây là các keyframe quan trọng cần nắm vững. 

c. Thêm và loại bỏ một câu hỏi 

* Thêm một câu hỏi vào bộ đề 

Bước 1. Trên layer thứ nhất của Timeline, chọn Frame đứng trước vị trí cần chèn câu 

hỏi. Giữ phím Shift, chọn các Frame khác cùng vị trí trên các layer còn lại. 

Bước 2. Bấm chuột phải lên các frame đó, chọn Insert Frames 

Bước 3. Trên Interactions Layer, chọn Frame vừa được chèn, chọn Insert -> Timeline -> 

Blank Keyframe 

Bước 4. Tiếp theo làm một trong các cách sau: 

Cách 1: Copy & Paste: Chọn một keyframe chứa câu hỏi dạng tương tự có thể sử dụng 

lại, bấm chuột phải lên timeline và chọn Copy Frames. Sau đó quay về keyframe trắng 

vừa chèn vào, bấm chuột phải lên keyframe đó, chọn Paste Frames. 

Cách 2: Sử dụng công cụ Library: Bật cửa sổ Library bằng lênh Window -> Other 

Panels -> Common Libraries -> Learning Interactions. Sau đó kéo kiểu câu hỏi từ cửa 

sổ này vào Stage. 

* Loại bỏ một câu hỏi khỏi bộ đề 

Bước 1. Trên Interactions Layer, chọn Keyframe chứa câu hỏi cần xóa. 

Bước 2. Chọn Edit -> Timeline ->Remove Frames 

d. Cấu hình cho các câu hỏi: 

Bước 1. Chọn câu hỏi (chọn keyframe chứa câu hỏi). 

Bước 2. Phá vỡ nhóm các đỗi tượng của câu hỏi: Thực hiện lệnh Modify -> Break Apart 

(lệnh này chỉ được dùng một lần). Để kiểm tra xem các đỗi tượng của câu hỏi đã được 

phá vỡ hay chưa, hãy thử chọn và kiểm tra một đối tượng như textbox, radio, checkbox 

trên Stage. Nếu có thể chọn riêng rẽ tức là đã thực hiện lệnh thành công. 

Bước 3. Hủy chọn tất cả các đối tương trên Stage (gõ Control + Shift+ A) 
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Bước 4. Bấm chọn Learning Interaction (thường nằm bên dưới Quiz Options). Cụm từ 

Learning Interaction sẽ được thay bằng tên của dạng câu hỏi. Trong ví dụ dưới đây, bạn 

sẽ bấm chọn Multiple Choice Interaction 

Bước 5. Chọn Window -> Development Panels -> Component Inspector để thay đổi 

kích thước cửa sổ cho phù hợp để có thể đọc được chữ, điền các giá trị theo từng dạng 

câu hỏi. 

e. Xây dựng câu hỏi  

- Dạng ghép đôi, sử dụng dạng Drag anh drop 

 

Hình 1. Công cụ tạo câu hỏi trắc nghiệm hình ảnh dạng ghép đôi 

- Dạng lựa chọn đối tượng, sử dụng dạng Hot Objects 

 

Hình 2. Công cụ tạo câu hỏi trắc nghiệm hình ảnh lựa chọn đối tượng 
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- Dạng lựa chọn vị trí trên một đối tượng, sử dụng dạng Hot Spot 

 

Hình 3. Công cụ tạo câu hỏi trắc nghiệm hình ảnh dạng lựa chọn vị trí trên đối tượng 

f. Chạy thử 

Trong quá trình tạo bộ đề, có thể chạy thử để kiểm tra lỗi bằng cách dùng lệnh: 

Control -> Test Movie 

g. Đóng gói bộ đề 

Đề trắc nghiệm vừa tạo có thể được đóng gói dưới hai dạng: 

Dạng 1: Dạng tệp tin flash (.swf), ở dạng này có thể tải lên trang web học tập để kiểm 

tra trực tuyến.  

Dạng 2. Dạng tệp tin chương trình (.exe), dạng này cho chạy độc lập như một ứng dụng 

của Windows, dùng để kiểm tra trực tiếp trên máy tính. 

Để đóng gói bộ đề thực hiện các bước sau: 

Bước 1. Vào File -> Publish Settings 

Bước 2. Trong Tab Formats, chọn dạng Flash (.swf) hoặc Windows Projector (.exe) tùy 

theo mục đích. Trong cột File điền tên tệp tương ứng. Chuyển sang Tab Flash hoặc 

HTML(phần này chú ý mục template chọn dạng chuẩn SCORM: Flash with SCORM 

1.2 tracking, chuẩn này tải lên được hệ thống quản lý học tập) để khai báo thêm các 

thông số cho việc đưa đề lên Web. 

Bước 3. Nhấn nút Publish để đóng gói bộ đề. 

4.3. Xây dựng bộ đề trắc nghiệm đồ họa học phần Kiến trúc máy tính 

Sau một thời gian nghiên cứu chúng tôi đã xây dựng thành công bộ đề trắc nghiệm dạng 

hình ảnh môn kiến trúc máy tính gồm 50 câu hỏi, sử dụng ba dạng câu trắc nghiệm như 

đã trình bày ở trên. Bộ đề này đã được sử dụng để kiểm tra đánh giá trong dạy học trực 
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tuyến học phần kiến trúc máy tính cho lớp TT1Đ15 – khoa CNTT – trường Đại học 

Công nghiệp Việt Trì tại địa chỉ www.khanhmckm.com. Cụ thể về các dạng câu hỏi đã 

được sử dụng để xây dựng bộ đề: 

Ví dụ 1: Câu trắc nghiệm hình ảnh dạng ghép đôi 

Cho 4 CPU và 4 socket, yêu cầu học viên lắp ráp CPU tương ứng với các socket trên 

mainboard 

 

Hình 4. Câu hỏi dạng ghép đôi 

Sinh viên sử dụng chuột, dùng thao tác kéo thả để lắp ráp. Trong quá trình lắp ráp nếu 

sinh viên muốn làm lại thì sử dụng nút Reset. Khi đã làm xong học viên chọn nút Check 

Answer để nộp bài, hệ sống sẽ báo kết quả của câu hỏi là đúng hoặc sai. 

 

Hình 5. Học viên thao tác lắp ghép lần lượt CPU vào socket tương ứng 
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Ví dụ 2. Câu hỏi trắc nghiệm chọn đối tượng 

Cho 6 CPU, yêu học viên lựa chọn CPU nào có từ 3 nhân trở lên 

 

Hình 6. Câu hỏi dạng lựa chọn 

Học viên lựa chọn CPU thỏa mãn yêu cầu đề bài, chọn nút Check Answer để nộp bài, 

hệ thống báo kết quả của học viên 

Ví dụ 3. Câu hỏi trắc nghiệm dạng chọn vị trí trên đối tượng 

Cho hình của một bo mạch chủ (Mainboard), yêu cầu học viên chỉ ra trên bo mạch đâu 

là socket. 

 
Hình 7. Câu hỏi trắc nghiệm dạng lựa chọn vị trí 
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Học viên chọn phần socket của main trên hình vẽ, chọn nút Check Answer để nộp bài. 

Hệ thống báo kết quả cho học viên. 

Sau khi học viên hoàn thành tất cả câu hỏi hệ thống sẽ đưa ra kết quả đánh giá bao gồm: 

+ Số câu trả lời đúng 

+ Số câu trả lời sai 

+ Tổng điểm 

 

Hình 8. Kết quả làm bài của học viên 

5. ĐÁNH GIÁ KẾT QUẢ TRIỂN KHAI BÀI KIỂM TRA TRẮC NGHIỆM ĐỒ HỌA 

Do khuôn khổ của bài báo, chúng tôi không trình bày các kết quả thực nghiệm mà chỉ 

đánh giá định tính. 

Đối với học viên: Việc sử dụng hình ảnh để đánh giá đã lôi cuốn được học viên tích cực 

tham gia và đánh giá được khả năng vận dụng vào thực tế, tư duy sáng tạo của học viên. 

Đặc biệt là đã hạn chế được những nhược điểm của đánh giá trực tuyến đối với những 

môn công nghệ (do không thể kiểm tra trên thiết bị thực). 

Đối với giáo viên: Thông qua bộ đề trắc nghiệm bằng hình ảnh đã kiếm tra đánh giá 

được học viên một số tiêu chí của các môn học công nghệ mà hình thức trắc nghiệm text 

khó có thể đáp ứng được trong dạy học trực tuyến như: Nhận dạng thiết bị, đọc thông số 

kỹ thuật, ghép nối thiết bị cũng như phân biệt các thành phần trong các hệ thống thực tế. 

6. KẾT LUẬN 

Cùng với sự phát triển của Công nghệ thông tin, trắc nghiệm đồ họa đang là vấn đề lớn 

đang được nhiều nhà sư phạm quan tâm, đặc biệt là trong dạy học trực tuyến những 

môn học công nghệ. Trong bài báo này tác giả đã giới thiệu việc sử dụng phần mềm 
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Macromedia Flash để tạ bài trắc nghiệm dạng đồ họa và việc vận dụng công cụ này xây 

dựng thành công bộ đề trắc nghiệm đồ họa học phần kiến trúc máy tính. Các kết quả thu 

được cũng có thể được sử dụng làm tài liệu tham khảo cho việc xây dựng đề trắc 

nghiệm bằng hình ảnh trong các môn học khác. 

 . 
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Title: USING THE MACROMEDIA FLASH SOFTWARE TO BUILD THE ONLINE 

GRAPHICS TEST FOR COMPUTER ARCHITECTURE MODULE 

 

Abstract: Objective tests in the assessment has been used in most of the courses at the 

University. Many issues raised in the construction of the test subject as difficult, shape and form 

of tests. Graphical test which enhance virtualization interoperability and enhanced quality of 

teaching, is issuese of interest. This article introduces how to use Macromedia Flash software in 

creating a number of different forms graphic questions. On that basis, we have applied to build 

the graphical test suite for Computer Architecture module. 
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